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Overview 
SmartLists with Export Options Used for ad-hoc queries in Great Plains.  Queries can be saved as 

Smartlist favorites to be used again.  The user enters restrictions and changes the columns displayed.  

This can be used to export query results to Excel and as a shortcut to data in GP.  Reports are not 

formatted unless Export Options is used to run macros to format the Excel file. 

SmartList Builder/Excel Reporter Used to create Smartlists other than those out-of-the-box with GP.  

Smartlists can be built to combine companies, pull third party data, and pull data from other databases.  

Excel Reporter was added to Smartlist Builder with the version 10 Feature Pack for Dynamics GP.  Excel 

Reporter is used to create refreshable Excel reports similar to Smartlist exports except that the data may 

be refreshed in Excel. 

Excel (MS Office) A powerful reporting tool that integrates with SQL data, FRx, Smartlists, Analysis 

Cubes, and SQL Reporting Services.  Pivot tables allow users to summarize and “slice and dice” a set of 

data in many ways.   

Analysis Cubes Used to allow users who are not familiar with database structures to write reports.  The 

cubes store a fraction of the data in the ERP system to allow users to dig into data.  Excel is the primary 

delivery method, but there are sophisticated OLAP viewers available.   

Dynamics GP has 2 cubes available:   

• Financial – GL, AR, AP, Bank Rec. 

• Distribution – SOP, POP, Inventory 

SQL Reporting Services (SQL Server) SRS is used to deliver reports via an intranet/internet to users 

throughout the organization – regardless of whether or not they are GP users.  SRS can combine data 

from multiple sources and multiple companies.  Reports are accessed using Internet Explorer and the 

security is controlled via the server.  Reports are designed in Visual Studio. 

• SRS Reports from MS – approx. 90 report templates available with version 10.  These can be 

modified in Visual Studio. 

• SRS Report Builder – a “light” version of SRS that uses report models to define the data that is 

available to users.  Users can create simple reports and make them available in the SRS Report 

Manager. 

 

Microsoft FRx (Report Designer, Report Launcher, Drilldown Viewer, Report Server, WebPort, Report 

Manager) Used for Financial Statements.  FRx pulls data from Microsoft Dynamics GP General Ledger, 

Excel, FRx Forecaster. 

 

**Report Manager creates Report Books that allow you to combine multiple files in one package. 
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Smartlists with Export Solutions 

Creating export solutions 

Use the Export Solutions window to create an export solution. Export solutions allow you to export 

search results to a template and run Excel or Word macros before or after exporting. 

To create export solutions: 

1. Open the Export Solutions window.  

(With SmartList open choose SmartList 

>> Export Solutions)  

2. Enter a name for the export solution.  

3. In the Document field, enter the path 

to the file containing the template that 

you want to use, or choose the file 

lookup button to locate the file.  

4. Enter the preparation macro—that is, 

the macro that you want to run before 

exporting to Excel or Word.  For 

example, you could use a preparation macro to clear data out of a pivot table in Excel before 

exporting.  

To run a macro after exporting to Excel or Word, enter the completion macro name. 

5. Select the users that this export solution should be visible to.  

6. Select the application to export to—Word or Excel.  

7. Expand an object in the Works for Favorites 

list and mark the box next to the favorite 

that you want to use the export solution for.  

8. Choose Save to save the export solution.  

To delete an export solution, select it and choose 

Delete. 

Choose New to clear the fields in the Export Solutions 

window. Then you can enter data to create a new 

export solution. 
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To export search results to Excel or Word: 

Be sure that the results to export are displayed 

in the SmartList window.  

Choose the Excel button or the Word button 

on the toolbar.  

If you have created an export solution to 

format your search results, choose the Excel or 

Word button to open a list of export solutions. 

Choose the Quick Export option to generate a 

spreadsheet or table automatically from your 

list of export solutions. 

If you have not created an export solution, 

choose the Excel or Word button to generate a spreadsheet or table automatically.  Column names in 

the spreadsheet or table correspond to column names in SmartList. 

**Be sure that the Preparation macro ends in cell A1 on Sheet1 so that the export will work correctly.  

The preparation macro should include steps to clear old data so that the refreshed sheet contains only 

the data you expect. 

**If the file specified in the Document Field is an existing file in Word or Excel, the export will overwrite 

the information in the file. If you would like to have a new file created on each export, the file listed in 

the Document field will need to be set up as a template. 

Smartlist Builder/Excel Reporter 

 

In Dynamics GP, go to Microsoft 

Dynamics GP > Tools > Smartlist 

Builder.  Choose Smartlist Builder or 

Excel Report Builder. 

In this tool, the user defines which 

table(s) and fields will be included in 

the reports.   

Add restrictions, define any calculated 

fields. 

Define whether the list is summarized, and if so, what operation is performed on each field. 
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Click on PUBLISH to create the report.  Choose to publish to a 

file or to SharePoint.   

The Excel file can now be opened.   

Click on Table Tools and refresh. 

Security is handled using database roles on the SQL Server.  If 

the user is not assigned a role that can access the data in the 

report, the report cannot be 

refreshed by that user. 

If the user can access the data, 

the data sheet is refreshed.  

Any tables or graphs using that 

data can then be refreshed 

without any additional steps. 

 

 

Analysis Cubes 

The Analysis cubes provide good examples for working with pivot tables.  Analysis cubes are pre-

programmed OLAP cubes.  Cubes organize the data in logical hierarchies.  The field names are 

descriptive.   Customer Name is called Customer Name instead of RM00101.CUSTNAME, for example. 

Pivot tables are a way to summarize data.  A pivot table can pull data from a range or table in Excel, or 

from external sources.  In earlier examples, the pivot table was created from an Excel sheet.  For cubes, 

the data is in the cube and a connection must be created. 

Choose the Data menu > From Analysis 

Services. 
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Select the cube based on the data needed.  

Financials – accounting data (GL and Bank 

Reconciliation) 

Receivables – AR  

Payables – AP 

Inventory – Inventory 

Sales – Sales Order Processing 

Purchases – PO Processing 

 

Click Finish on the next screen. 

 

 

 

 

 

 

A template will open in Excel.  In 

earlier versions of Excel, the 

template is on the worksheet.  

The labels are the same as in the 

Pivot Table box below.  Drag and 

drop fields to place them in the 

table.  If the fields need to be 

moved, drag them to the new 

location or out of the table 

entirely. 

Report Filters – Restrictions.  

The data in the table will change 

based on these fields. 
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Row Labels – These are the 

rows in the table. Multiple 

fields result in subtotals.   

Column Labels - These are the 

columns in the table. Multiple 

fields result in subtotals.   

Values (data fields) – These are 

the summarized fields.  To 

change the summary option, 

click on the down arrow on the 

field and choose Field value 

settings.  In earlier versions of 

Excel, right-click on the field in 

the pivot table and choose 

Field value settings.  Formats 

are also set from this menu. 

If you choose a hierarchy from the list, you will 

be able to drill down to a lower level of detail in 

the cube.  The cubes organize the data and the 

organization is reflected in the pivot table 

structure. 

In earlier versions of Excel, an Analysis add-in is 

required to use some of the cube functionality.  

In 2007, it is more seamless.  These examples 

are in pivot tables, but more formatted reports 

are possible.  Create the table, then go to Pivot 

Table Tools > OLAP Tools > Convert to formulas 

to create a formatted report. 

Use formulas as normal.  Type 

in the cell references – do not 

select cells from the pivot 

table. 
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Make sure to continue the formulas down the column to allow for additional data when the pivot table 

is refreshed.  Use conditional formatting to hide the errors due to empty lines. 

 

Dashboards are reports that 

highlight important information 

graphically.  When the Pivot Table 

tools ribbon is available, choose 

to insert a chart.  Define the type 

and other options as normal. 

You can have multiple reports on 

one sheet.  To refresh all tables 

and graphs, click on Data > 

Refresh All. 

 

 

 

 

MS Query 

 

If only one table is needed, use “From SQL 

Server”.  Otherwise, use “From Microsoft 

Query”.  This allows joining multiple tables for a 

more complex query. 

 

 

 

Select the ODBC data source.  An ODBC connection is specific 

to each workstation, so be sure to use the same name on all 

workstations that will be using the Excel reports.  
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Select the tables and fields needed. 

The wizard will step through entering restrictions and 

sorts.  

It will then ask whether to return the data to Excel or to 

open MS Query.  If opened in MS Query, the query can 

be refined as needed. 

 

The result is a data sheet that can be filtered, pivoted, or charted to provide the information needed. 
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Go to Insert > Pivot table.  Click in the data range to select the data.  Change the reference to use the 

entire column to allow for more data upon refresh. 

Right-click on the pivot header to open the menu of additional options.  The options available depend 

on which cell is clicked and the data type of the data element. 

Right-click on the label itself for more grouping and sorting options.  For example, group date fields by 

month or year rather than by day. 

There are also menus for data and value filtering.  For example, include only transactions in the current 

month or only those greater than $1000. 

Rows and columns can be restricted on the fly to include only certain values.  Changing this restriction 

changes the data displayed in the table. 
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SQL Reporting Services  

MS Dynamics GP Report Templates 

SQL Reporting Services (SRS) is used to deliver reports via a web browser to users throughout the 

organization – regardless of whether or not they are Dynamics GP users.  SRS can combine data from 

multiple sources and multiple companies.  Reports are accessed using Internet Explorer and the security 

is controlled via the server.  Reports are designed in Visual Studio. 

There are approximately 90 SRS report templates available with version 10.  These can be modified in 

Visual Studio.  The out of the box templates are shown below.  Also available are report models for the 

most commonly used data.  These are used for Report Builder but can also be used for reports built in 

Visual Studio. 
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Users access reports using Internet Explorer based on the rights they have been granted. 

On the SQL server, the path will be similar to this one: 

http://localhost/reports/Pages/Folder.aspx 

On other machines, the server name will replace local host. 

A user with administrator rights will see the report model and datasource folder as well as a folder for 

each Dynamics GP company. 

 

Drilling into the TWO company shows subfolders for each report category. 

 

Within each folder, the reports are visible.  Click on a report to launch it.  The GL Trial Balance Detail is 

shown. 
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The user fills out the parameters at the top of the report then clicks the VIEW REPORT button. 

The parameters section of the screen can be collapsed for ease of report viewing. 

 

The report may be viewed on the screen, printed, or exported in a variety of formats. 
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The reports export to 

Excel much more 

cleanly than Report 

Writer reports. 

 

 

 

 

 

 

 

The report layout in Visual Studio is complex.  A technical person familiar with SRS can modify the 

report, save it and deploy it to the Report Manager. 
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SRS Report Builder 

SRS Report Builder is a limited version of SRS that uses report models to define the data that is available 

to users.  Users can create simple reports and make them available in the SRS Report Manager. 

 

Users who are granted rights to use the Report Builder will see the Report Builder button on the home 

page of the Report Manager. 

Use the Report Builder window in design mode to design, manipulate data within, and preview your 

reports. In Design mode, the Report Builder window is divided into several areas: the Explorer pane, the 

design area, and the Report Layout pane. 

In Design mode, you can:  

• Explore the data available to you. 

• Select the fields you want to display in your report. 

• Drag and drop fields into the report. 

• Position selected fields within the report. 

• Apply filters. 

• Create formulas. 

• Sort and group the data in the report. 

• Preview the results. 

• Adjust the size of the rows and columns within the report. 

• Format all items within the report. 

Use to create a new field that contains a formula. 

In the Report Manager, click the Report Builder button. 
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The Report Builder opens 

with a blank screen.  

Select the Data source 

and type of report on the 

right. 

 

 

 

 

 

 

 

The entities (groupings of 

data) are on the top left. 

Fields available are on the 

bottom left. 

Drag fields onto the 

report template in the 

center. 

Other fields can be 

created under the Report 

menu > Add fields. 

Fields are formatted once 

they are on the report by 

right-clicking the fields 

and selecting the format. 

Type a title on the report 

in the indicated location. 
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As you drag fields onto 

the report, they are 

displayed on the 

template (blue).  To 

remove fields, right-click 

and delete. 

 

 

To add a filter, click the Filter button.  The filter 

window opens.  Select the field to be filtered and 

create the restriction.   

 

 

 

 

 

 

To create a new field, click on the Report menu > New 

Field.  Use the Fields tab to select the field and enter the 

expression for the field.  Formula syntax is like Excel 

formulas.  For example, an if statement uses the 

following syntax: 

IF(logical test, true result, false result)  

To create a field that is a positive number if the 

document is an invoice, but negative if it is not, the 

expression is: 

 

=IF(Document type = “Invoice”, Current Trx Amount, (Current Trx Amount * (-1))) 

If it is necessary to edit a formula, select the field from the field list on the left – not from the report.  It 

is not possible to edit the field from the report template, but any changes to the field will automatically 

be applied to the field on the template. 
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To create subtotals for this field, create a second 

field to sum the first one.  Use the Aggregate tab. 

 

 

 

 

 

 

The formula is SUM(fieldname).  Select the field from 

the left to insert into the formula. 

 

 

 

 

Adding the new aggregated field to the report adds subtotals for every group (green).  Format the 

subtotals by right-clicking on each and choosing the desired format. 

 

 

Click the Run Report button to preview the report.  Click the Design Report button to make any changes. 
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Saving the report will deploy it to the Report Manager.  Select the location of the report.  The report can 

then be run from the Report Manager.  

 

The report will be displayed as “New!” 
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User rights are defined in SQL Reporting Services.  Users are assigned roles that determine whether they 

are allowed to run reports only, edit existing reports, or create reports, but only to a “My Reports” 

folder, and so on. 

 

 

 

 

Microsoft FRx 
Microsoft FRx is made up of several applications – all related to producing financial statements.  FRx 

reports can be exported to Excel as a formatted report or as a pivot table/chart.  Other export formats 

include XBRL and HTML. 

FRx Report Designer: Create and edit reports. 

FRx Report Launcher:  Run reports, setting the report date, file format for export, and other parameters.  

The user cannot edit report templates. 

FRx Drilldown Viewer:  View existing reports generated in Report Designer or Report Launcher.  Export 

to other formats.  The user cannot generate new reports. 

FRx Report Server:  Schedule FRx reports and offload ad hoc reports to a server for generation. 

FRx Webport:  Secure intranet site to access reports published from FRx Report Designer. 
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FRx Report Manager: Combine multiple FRx reports with other files to create a report package.  Publish 

the files to a Drilldown viewer file for ease of access, or to a network folder to be accessed as needed.  

Generate the entire report package at once and print if necessary. 

 

Files are organized in the 

Report Manager (left).  When 

the report book is published, 

choose the destination location 

and type. 

Publishing to a file creates 

subdirectories that mirror the 

report book. 
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Macros in Excel 2007 

Record a macro 

When you record a macro, the macro recorder records all the steps required to complete the actions 

that you want your macro to perform. Navigation on the Ribbon is not included in the recorded steps.  

 NOTE    The Ribbon is a component of the Microsoft Office Fluent user interface. 

1. If the Developer tab is not available, do the following to display it:  

1. Click the Microsoft Office Button , and then click Excel Options.  

2. In the Popular category, under Top options for working with Excel, select the Show 

Developer tab in the Ribbon check box, and then click OK. 

2. To set the security level temporarily to enable all macros, do the following:  

1. On the Developer tab, in the Code group, click Macro Security.  

 

2. Under Macro Settings, click Enable all macros (not recommended, potentially dangerous 

code can run), and then click OK.  

 NOTE    To help prevent potentially dangerous code from running, we recommend that you 

return to any one of the settings that disable all macros after you finish working with macros. 

For more information about how to change the settings, see Change macro security settings in 

Excel. 

3. On the Developer tab, in the Code group, click Record Macro.  

4. In the Macro name box, enter a name for the macro.  

 NOTE    The first character of the macro name must be a letter. Subsequent characters can be 

letters, numbers, or underscore characters. Spaces cannot be used in a macro name; an 
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underscore character works well as a word separator. If you use a macro name that is also a cell 

reference, you may get an error message that the macro name is not valid. 

5. To assign a CTRL combination shortcut key to run the macro, in the Shortcut key box, type any 

lowercase letter or uppercase letter that you want to use.  

 NOTE    The shortcut key will override any equivalent default Excel shortcut key while the 

workbook that contains the macro is open. For a list of CTRL combination shortcut keys that are 

already assigned in Excel, see Excel shortcut and function keys. 

6. In the Store macro in list, select the workbook where you want to store the macro.  

TIP  If you want a macro to be available whenever you use Excel, select Personal Macro 

Workbook. When you select Personal Macro Workbook, Excel creates a hidden personal 

macro workbook (Personal.xlsb) if it does not already exist, and saves the macro in this 

workbook. In Windows Vista, this workbook is saved in the C:\Users\user 

name\AppData\Local\Microsoft\Excel\XLStart folder. In Microsoft Windows XP, this workbook 

is saved in the C:\Documents and Settings\user name\Application Data\Microsoft\Excel\XLStart 

folder. Workbooks in the XLStart folder are opened automatically whenever Excel starts. If you 

want a macro in the personal macro workbook to be run automatically in another workbook, 

you must also save that workbook in the XLStart folder so that both workbooks are opened 

when Excel starts. 

7. In the Description box, type a description of the macro.  

8. Click OK to start recording.  

9. Perform the actions that you want to record.  

10. On the Developer tab, in the Code group, click Stop Recording .  

TIP  You can also click Stop Recording on the left side of the status bar. 

 


